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1. Introduction

To add audio-text synchronization to apps built with Reading App Builder, you need to
create a timing file to go alongside each audio MP3 file. The timing files provide the
information the app needs to highlight phrases in the text as the audio is playing.

You can choose between two different methods to create the timing files:

1. Audacity: listen to an audio file in the Audacity audio editor and lay down a
labels track, placing a label at the start of each phrase.

2. aeneas: an automated method of synchronizing text and audio.

This document takes you through the first of these methods: using Audacity to create
the timing files. Instructions on the other method can be found in the user manual
Using aeneas for Audio-Text Synchronization.

PLEASE NOTE:
Many users of Reading App Builder are finding that aeneas is providing very
accurate synchronization results, so we do recommend you try it out.

One timing file for each audio file
To synchronize audio and text in your app, you will need:

e one MP3 audio file and one timing file per chapter, or

e one MP3 audio file and one timing file per picture story book.

For example, if you have a book ‘History of Mali’ with 20 chapters, you will need 20
audio files and 20 timing files. If you have a picture story book with 8 pages, you need a
single audio file which covers all 8 pages together with a single timing file.

Example: if you have an audio file for ‘History of Mali’ chapter 1, History_Mali_01.mp3,
you need to create a corresponding timing file, e.g. History_Mali_01.txt.

Note: If you have several audio files per chapter or several chapters in one audio file,
you will need to concatenate or split your files to create files of one chapter each before
creating the timing files. This could be done in Audacity.



Timing files

A timing file for a single chapter will look like this, with a line for the timing of each
phrase to be highlighted:

8.252945 8.252945 a
16.401422 16.401422 b
27.235258 27.235258 c
33.809408 33.809408 d
66.545898 66.545898 e
74.952265 74.952265 bl
96.749997 96.749997 g
111.571459 111.571459 h
127.398309 127.398309 i
130.636807 130.636807 ]
149.545453 149.545453 k
157.938255 157.938255 1
172.479752 172.479752 m
190.809003 190.809003 n
206.453448 206.453448 o)
217.292729 217.292729 P
229.985550 229.985550 g

The first and second columns indicate the time in seconds. The third column contains
the phrase label (a-z).

For a longer chapter, you will soon run out of letters of the alphabet. When you get to
“z”, the next label you need to use is “aa”, then “ab”, “ac”, “ad”, etc. When you get to
“az”, the next label you need to use is “ba”, then “bb”, “bc”, “bd”, etc. In other words,
this follows a similar naming convention to the column names in a spreadsheet.

o n

Phrases can be between punctuation marks, e.g. up to the next “.” or “,”. You can define
the set of punctuation characters that mark the end of a phrase. Individual poetic lines
can also be highlighted one by one, for example in a psalm or a song.

A timing file for a picture story book will look like this, with the number representing
the page of the book and the letter representing the phrase within that page:



0.000 2.920 la
2.920 5.840 1b
5.840 10.080 lc
10.080 13.560 2a
13.560 15.260 2b
15.260 17.240 2c
17.240 19.020 2d
19.020 21.540 2e
21.540 24.560 2f
24.560 27.660 3a
27.660 30.060 3b
30.060 32.620 3c
32.620 36.140 3d

Word level highlighting:

If you want to split a phrase after one or more words, you can use word-level
highlighting for that phrase. For this, the labels in the timing files should contain an
underscore and then the index of the word, e.g.

a4 starts at the 4th word of the first phrase (a)
b 5 starts at the 5th word of the second phrase (b)
b 9 starts at the 9th word of the second phrase (b)

A timing file with word-level phrase breaks might look like the following example:

3.188682 3.188682 a
7.415084 7.415084 a 4
12.934091 12.934091 a 11
16.746603 16.746603 b
17.356305 17.356305 b 5
18.853311 18.853311 b 9
19.829615 19.829615 c
20.905796 20.905796 d
21.884018 21.884018 e
22.858863 22.858863 f
25.613723 25.613723 g
27.108508 27.108508 h
28.839213 28.839213 i 6
29.158316 29.158316 i 10
30.192832 30.192832 ]
31.388587 31.388587 k
32.683989 32.683989 1
36.440027 36.440027 m
38.297624 38.297624 n




2. Getting Started

2.1. Phrase Lists

To help you identify when to mark a timing break, we recommend you create Phrase
Lists. These will arrange the phrases line by line for you.

To create phrase lists for each of the chapters in your app:
1. Launch Reading App Builder.
2. Navigate to the Book Collection page for your app.
3. Go to the Audio Synchronization tab.
4

Click on Create Phrase Lists and follow the instructions in the wizard.

A set of Word documents (.docx), comma-separated files (.csv) or tab-separated files
will be created, one for each chapter.

A phrase list document for a single chapter looks like the following:

Chicken and Millipede 1

a Chicken and Millipede were friends.

b But they were always competing with each other.

c One day they decided to play football to see who the best player was.
d They went to the football field and started their game.

e Chicken was fast,

f but Millipede was faster.

g Chicken kicked far,

h but Millipede kicked further.

i Chicken started to feel grumpy.

J They decided to play a penalty shoot-out.

k First Millipede was goal keeper.

1 Chicken scored only one goal.




Each row in the phrase list document represents a separate timing phrase which will
need to be marked.

You can define which characters are recognised as phrase ending characters in the

Features > Audio page of Reading App Builder. By default, it is: a full stop/period (.), a
question mark (?), an exclamation mark (!), a colon (:) and a comma (,).

A phrase list document for a picture story book looks like the following:

Chicken and Millipede

1 Chicken and Millipede were friends.

But they were always competing with each other.

One day they decided to play football to see who the best player was.

2 They went to the football field and started their game.

Chicken was fast,

but Millipede was faster.

Chicken kicked far,

but Millipede kicked further.

Chicken started to feel grumpy.

3 They decided to play a penalty shoot-out.

First Millipede was goal keeper.

Chicken scored only one goal.

Then it was the chicken’s turn to defend the goal.




2.2. Installing Audacity

Install the Audacity sound-editing program if you do not already have it. Please see
Appendix: How to install Audacity.

M Audacity

3. Producing Timing Files

1. Launch Audacity.

2. Open the MP3 file using File > Open on the main menu.

3. If the file is stereo with two tracks, it can be helpful to reduce it to mono for this
process so it doesn’t take up so much room on your screen. Do this with Tracks >

Stereo Track to Mono.

4. Zoom in a couple of times so it is easier to see the gaps between the audio
waveforms.
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Stopped.

5. Have the Scripture text or Phrase List open to the chapter you will be listening to.

You could display the text in a different window (i.e. have Audacity take up the
left part of the screen and the Scripture text on the right, or have the screens



arranged at the top and bottom of the screen), but this can be awkward since
you will need to scroll the text from time to time and then click in the Audacity
window to give it focus again. While you are doing this you might lose your place
and miss a phrase break. What can work better is if you have a printed text in
front of you or if the text is already on a smartphone or tablet. Then you can
concentrate more fully on the text and avoid the complication of switching
between windows.

6. Move the cursor to just before the beginning of the first phrase (i.e. after any titles
or chapter headings).

7. Place the first label marker using CTRL-B. A label track will be created.

If you are using a Mac, the shortcut to use is Command B.
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Stopped. Actual Rate: 44100

8. Type the first label, such as “a”. This indicates that “phrase ‘a’ starts here”. (Look at
the phrase list document to tell you which label to use. In the case of a picture story
book, the first label will be “1” rather than “a”.)

The cursor should already be in the label, so you just need to press the “a” key
after pressing CTRL+B above.

9. Press ‘Play’ to start listening to the audio. As you listen, place a label at each timing
break using CTRL-M.

10



You don't really need to look at Audacity for this. Just follow the text closely and
keep pressing CTRL-M at the phrase breaks.

If you are using a Mac, the shortcut to use is Command . — that is Command and
period (.) together.

Windows Mac
Add Label At Sglgctlon CTRL-B Command B
(at cursor position when paused)
Add Label At Play!oack Position . . CTRL-M Command .
(at current position when playing audio)

Default key mappings for adding labels

Usability Tip: Instead of pressing two keys together (CTRL-M) to add a label, it is
easier if you reassign the key binding to be a single key, such as F1. See Section 4:
Usability Tips for more details on how to do this.

10. When you get to the start of a new phrase, type the label while the audio is still
playing.

If you are quick, you’ll find there is no need to stop the audio for this. The cursor
is in the new label already so all you have to do is type the letters or numbers. If
you miss typing a label, you can always come back to it at the end.
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Playing. Click and drag to select audio, Ctrl-Click to scrub, Ctrl-Double-Click to scroll-scrub, Ctrl-drag to seek Actual Rate: 44100

If you lose your way, stop playback, move back a few seconds and press play
again.

11



To delete a label you have placed by accident, press the DELETE key when the
label is selected.

11. When you have finished placing labels for the whole chapter or picture story book,
go back to each label :

i. Move it slightly if you missed the middle of the blank section between
phrases. Do this by dragging the circle in the middle of the marker.

ii. Type timing labels into the small white boxes in the label track if you didn’t
do this earlier.
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Stopped. Click and drag to select audio, Ctrl-Click to scrub, Ctrl-Double-Click to scroll-scrub, Ctrl-drag to seek Actual Rate: 44100

Another way of adding labels is via Tracks > Edit Labels... This is an easier way
to add timing labels quickly. You can also delete unwanted labels here.

Edit Labels *

Press F2 or double dick to edit cell contents.

Track Label Start Time End Time -
1 1 -Label Track |a 00h0OOm02,312s 00ho00m02.912s
2 1 -Label Track b 00h 00 m 10.031s 00hO00m 10.031s
3 1 -Label Track C 0Dh00Om21.558s 00h00m21.558 s
4 1 -Label Track d 00 h 00 m 30.000 = 00 h 00 m 30,000 s
5 1 -Label Track e 00h 00 m 35,350 s 00 h00m 35.950 5
]
Insert After Insert Before Remove Import... Export...

Cancel

12



During this process you will be able to see if you have missed out a phrase
somewhere or if you have added an unwanted marker that needs to be deleted.

12. Export the label track to a text file using File > Export Labels... Choose a name
such as My-Book-01.txt (for chapter 1), My-Book-02.txt (for chapter 2), etc.

13. Open the timing file in a text editor such as Notepad. You should see something like
this:

3.188682 3.188682 1
7.415084 7.415084
12.934091 12.934091
16.746603 16.746603 2
19.829615 19.829615
20.905796 20.905796
21.884018 21.884018 3
22.858863 22.858863
25.613723 25.613723 4
27.108508 27.108508
30.192832 30.192832
31.388587 31.388587
32.683989 32.683989 5
36.440027 36.440027
38.297624 38.297624

14. The three columns are From, To and Label. Make sure all the timing labels are
present. If you have missed out a label somewhere, fix it in the text file or within
Audacity and export again.

The timing file is now ready to be used in an app.

13



4. Timing Labels Assistant

If you are using Audacity in Windows, there is a helpful utility program that will make
marking labels significantly easier. It is called Timing Labels Assistant (TLA).

TLA is built with AutoHotKey to simulate keystrokes in Windows. It allows you to specify
a phrases file and will insert the label name (a, b, etc.) for you automatically when you
press the key to add the next label.

You can find it here: https://github.com/indiamcqg/timing-labels-assistant

Download the zip file, Timing-Labels-Assistant_v1.2.29.zip (or a later version), and
unzip it to a writable folder on your computer (i.e. not in Program Files). The main TLA
executable is called Timing-Labels-Assistant.exe.

To use TLA:

1. Run the Create Phrase Lists wizard within Reading App Builder to create a set of
tab-delimited .phrases files for the book chapters you want to synchronize.
That’s the 3rd option in the choice of file types.

2. Open Audacity with the audio file to be synchronised and zoom into the
waveform 2-3 times.

3. Launch Timing-Labels-Assistant.exe.

4. Choose the .phrases file corresponding to the audio file you have open in
Audacity. It will be opened for you in Notepad.

5. Arrange Notepad to the side of your Audacity window so you can see both.
6. Start playing the audio.

7. Press the TAB key or the + key on the numeric keyboard to place a marker. (This
much easier than pressing CTRL+M). The markers will appear in the order they
are in the .phrases file.

If markers do not appear when you press TAB or +, check that CTRL+M is
still associated with the command Add Label at Playback Position. See
section 5.2 for more details.

8. You will hear a beep when the list of markers comes to an end.

To restart from a given label:

e Click on the icon in the taskbar and select Restart timing at label....
e Enter the label you want to start from, e.g. b.
e Press OK and continue from step 6 above.

To exit:

e Click on the icon in the taskbar and select Exit.

14
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5. Usability Tips
5.1.Tip #1: Change the keyboard binding for the spacebar

By default, the spacebar is assigned to Play/Stop. This is good, but the problem is that if
you stop somewhere and then start again, the playback goes back to the original start
position rather than playing from where you stopped.

To modify this:
1. Go to Edit > Preferences > Keyboard.

2. Select the line Play/Stop and Set Cursor. To find this quickly, type ‘play/stop’
into the Search field at the top.

You are looking for the line that ends with ‘...and Set Cursor’ rather than simply
‘Play/Stop’.

Preferences: Keyboard >

- Devices Key Bindings
- Playback Viewby: () Tree @ pMame (JKey  Search: | play /stop |
- Recording

Flay/Stop Space

-~ Quality Play/Stop and Set Cursor Shift+A

- Imterface

- Tracks

- Import [ Export
- Extended Impart
- Prajects

- Libraries

- Spectrograms

- Directories

- Warnings

- Effects

- Keyboard

- Mouse Shift+a Set Clear

- Modules

Import... Export... Defaults

Cancel

3. Change the key binding for this line to Space (rather than Shift+A).

4. Press Set.

15



5. You will be asked if you want to make the change. Click OK to do this.

Error ot

e The keyboard shortcut 'Space’ is already assigned to:
‘Transport - Play/Stop’
Click OK to assign the shortcut to
‘Transport - Play/Stop and Set Cursor'

instead., Otherwise, click Cancel,

QK Cancel

6. Click OK to save the changes to the Preferences.

5.2.Tip #2: Change the keyboard binding for adding a label

Instead of pressing two keys together (CTRL-M) to add a label, it is easier if you reassign

the key binding to be a single key, such as F1. Then you have one hand free to type the
labels.

NOTE: This tip is only useful if you are not using Timing Labels Assistant (TLA). If you are
using TLA, you need to keep CTRL-M as the key combination to add a label.

To change the keyboard binding for adding a label:
1. Go to Edit > Preferences > Keyboard.

2. Select the line Add Label at Playback Position. To find this quickly, type ‘add
label’ into the Search field at the top.

16



3. Type the key you want to use instead of CTRL-M, such as F1.

Preferences: Keyboard

- Devices

- Playback

- Recording

- Quality

- Interface

- Tracks

- Import / Export
- Extended Import
- Projects

- Libraries

- Spectrograms
- Directories

-+ Warnings

- Keyboard

- Mouse

- Modules

Key Bindings
view by: () Tree (@) pame () Key

Add Label At Playback Position Ctrl-+HM

Add Label At Selection

x

Search: | add label

Cirl+B

| Ctrl+M

|| s

Clear

| Import... || Export... || Defaults |

Ok

I | Cancel

4. Press Set.

5.

Preferences: Keyboard

- Devices

- Playbadk

- Recording

- Quility

- Interface

- Tracks

- Import [ Export
- Extended Impart
- Prajects

- Libraries

- Spectrograms
- Directories

- Warnings

- Keyboard

- Mouse

- Modules

Key Bindings
View by: () Tree (@ Mame ()Key

Search: | add label

Add Label At Flayback Position
Add Label At Selection

Fi
Ctrl+B

||=1

Clear

| Import... || Export... || Defaults |

Ok

| | Cancel

you will be asked if you want to make the change. Click OK to do this.

17

If the keyboard shortcut you have chosen is already in use for another function,




Error

e The keyboard shortcut 'F1' is already assigned to:
‘Cormmand - Selection Teol'
Click OK to assign the shortcut to
Tracks - Add Label At Playback Position'

instead. Otherwise, click Cancel,

QK Cancel

6. Click OK to save the changes to the Preferences.

18



6. FAQ

6.1. How can | change the punctuation characters which are recognised as ‘end
of phrase’ marks?

You can define which characters are recognised as phrase ending characters in the
Features > Audio page of Reading App Builder.

You can add Unicode characters here using the format \uUABCD where ABCD is the

hexadecimal Unicode code point, e.g. \uO61F for an Arabic question mark, \u1362 for
an Ethiopic full stop.

6.2.How can | get it to highlight section headings?

In some audio files, the section headings are read out by the narrator as well as the
main text. To include them in the highlighting, use labels ‘s1’, ‘s2’, ‘s3’, etc., where ‘s1’ is
the first section heading, ‘s2’ is the second section heading and so on.

Note that the ‘s’ is lower-case and there is no space between the ‘s’ and the number.

Use this same method for other types of headings, e.g. use ‘d’ as the prefix for \d
headings, ‘sp’ as the prefix for \sp headings, ‘is’ for \is, etc.

For section headings in picture story books, add the page number before the label, e.g.

1s1, 1s2, 1s3 for section headings on the first page; 2s1, 2s2, etc. for section headings
on the second page.

19



6.3. There are parts of the audio where | don’t want any text highlighted. How
can | turn off the highlighting for a few moments?

You might want to turn off text highlighting during musical interludes or sound effects.
To do this, you need to give the labels a range, rather than being at a single point.

Here is an example:
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File Edit View Transport Tracks Generate Effect Analyze Help
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>R
. (S @ L | @ W 0o | @] 2|2 |A L e g
MME w ﬁ Microsoft Sound Mapper ~ | 1 (Mono) Reco ~ | 4 |Microsoft Sound Mapper
I5 L 1|0 o 1|5 L 2|0 o 2|5 L 3|0 o ||<] i 3|5 L 40

X | Chicken | 1.0
Mono, 44100Hz

32-bit float 05-
Mute Solo
- + | 0.0
@
r R |-05-
@
-1.0
x| Label Track ¥ [ m [ . [ [ m [ n
.l:
& G——————0 & &
R | |
v
< >
Project Rate (Hz): Snap To: Selection Start: @®End () Length Audio Position:
44100 ~ Off ~ |00h00m33,045 5™ |00h00m33.0455' 00hO00OmMOOD.000 5™
Stopped. Click and drag to select audio, Ctrl-Click to scrub, Ctrl-Double-Click to scroll-scrub, Ctrl-drag to seek Actual Rate: 44100

In the above timing file:

e Phrase “b” highlighting will start at the “b” label and end at the beginning of the
“c” label (as normal).

e Phrase “c” highlighting will start at the initial point of the “c” label range and
continue until the end of the “c” label range.

e Nothing will be highlighted between the end of the “c” label range and the “d”
label.

e Phrase “d” highlighting will start at the “d” label.

To create a label range, drag the < or > part of the label marker.

6.4.1'd like to give someone else the task of creating timing files. Is there any
way of them testing these without needing to know how to build the app?

Yes, if you have chosen Audio Distribution by external folder or download, the MP3 files
will be in a folder on the SD card. The app will look for a corresponding timing file in this
folder if it doesn’t already have a timing file packaged inside the APK.

20



The timing filename in this case should be same as the mp3 file, but with the .txt
extension rather than .mp3.

So, for example, if you have a file such as My-Book-01.mp3 in the folder, you can put
the file My-Book-01.txt in the same place and the app should recognise it.

Using this method, others can work on providing timing files for the app and test them,
without needing to rebuild the app. Once the timing files are working, you can rebuild
the app and package them inside the apk. They are very small so should not increase
the size of the apk significantly.
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7. Appendix — How to Install Audacity

1. Download the latest Audacity installation program from the Audacity website:

http://www.audacityteam.org

For version 2.1, the filename is audacity-win-2.2.0.exe. It is 19 MB in size.
audacity-win-2.0.exe
m Audacity Setup
Audacity Teamn

It might be that a newer version than 2.2.0 is available. If so, download this newer
version instead.

2. Double-click audacity-win-2.2.0.exe to start the installation.

3. Select English as the language to use :

Select Setup Language X

Select the language to use during the
Q installation:

English Y
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http://www.audacityteam.org/

The Setup Wizard opens:

b Setup - Audacity® — *

Welcome to the Audacity® Setup
Wizard

This will install Audacity 2.1.1 on your computer,

Itis recommended that you dose all other applications before

& continuing.
“ ac Ity Click Mext to continue, or Cancel to exit Setup,

4. Click Next to continue.

A page of licence information will appear:

5 Setup - Audacity® - pd
Information
Flease read the following impartant information before continuing.

When you are ready to continue with Setup, dick Mext.

Audacity® is free, open source software for recording and editing ~
sounds. It is available for Mac 05 ¥, Microsoft Windows, GMU/Linux,

and other operating systems. Learn more about Audacity... Also check

our Wiki and Forum for more information.

License: Audacity is free software. You may use it for any personal,
commercial or educational purpose, including installing it on as many
different computers as you wish. Audacity is licensed under the terms
of version 2 of the GNU General Public License (GPL] as published by the
Free Software Foundation. The full text of the license is also availakle
when running Audacity, via the Help menu = About Audacity... command
» GPL License tab.

5. Click Next to continue.
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You will see the page Select Destination Location:

b Setup - Audacity® — .
Select Destination Location
Where should Audacity ® be installed? m

Setup will install Audacity® into the following folder,

To continue, dick Mext, If vou would like to select a different folder, dick Brawse,

[e: Program Fies (38) udsaiy] Bromse. .

At least 50.9 MB of free disk space is required.

6. The suggested location in which to install Audacity is normally fine, so click Next.

You’ll see the Select Additional Tasks page:

b Setup - Audacity® — *
Select Additional Tasks
Which additional tasks should be performed? m
Select the additional tasks you would like Setup to perform while instaling Audacity @,
then dick Mext.

Additional icons:

Create 3 desktop icon!

[] Reset Preferences
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7. Click Next to continue.

You’ll then see the Ready to Install page:

§b Setup - Audacity® — !
Ready to Install
Setup is now ready to beqin instaling Audacity® on your computer, 5

Click Install to continue with the installation, ar dick Back if yvou want to review or
change any settings.

Destination location:
C:'Program Files (x86)\Audacity

Additional tasks:
Additional icons:
Create a desktop icon

8. Click Install to begin the installation.

5 Setup - Audacity ® - pd
Installing
Please wait while Setup installs Audacity ® on your computer, o
Extracting files. ..

C:\Program Files (x3a)\Audadtyhelpimanualimiimages\g8\8fizoom3.png

E Cancel
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When the installation is complete, you will see a page of information:

€3 Setup - Audacity ® _

Information
Please read the following impartant information before continuing.

When you are ready to continue with Setup, dick Mext.

Audacity(R): A Free, Cross-Platform Digital Audio Editor
WWW http: /faudacityteam.ora/

We welcome feedback on Audacity, suggestions for new or improved features,
bug reports and patches at:
feedback @audacityteam.org .

Personal suppart with Audacity is not provided by e-mail, but on our Forum:
http: /faudacityteam. org forumy .

Audadity is copyright {c) 1999-2015 by Audacity Team. This copyright notice
applies to all documents in the Audacity source code archive, except as
otherwise noted (mostly in the lib-src subdirectories).

bt 1 o s P TR 1 1 " - .- -

9. Click Next to continue.
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You will then see the final page of the Setup Wizard:

€3 Setup - Audacity ® _

Completing the Audacity® Setup
Wizard

y |
MM Setup has finished installing Audacity® on your computer, The
application may be launched by selecting the installed icons,

L] Click Finish to exit Setup.
A“dﬂﬁltj Launch Audacity:

10. Click Finish to close the Setup Wizard and launch Audacity.

Audacity is now ready to use.
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