
PrimerPro Primer Making Tutorial 

PrimerPro is a computer application designed to assist literacy personnel in the creation of 

scientifically designed primers, by capitalizing on the grammatical and phonological properties 

of these languages. The program and accompanying instructions help primer developers 

determine the teaching order of consonants, find buildable words for stories, check stories for 

untaught letters, and perform other key tasks in producing reading primers. 

This tutorial is a step by step procedure on how to use PrimerPro to assist you in producing a 

primer.  The tutorial will walk through one scenario for using PrimerPro for producing a primer.  

Please note that there are other scenarios for using PrimerPro that are just as valid.  Once you use 

this tutorial for learning PrimerPro, you should feel comfortable on how to use PrimerPro in your 

situation.  This tutorial assumes that PrimerPro has already been setup on your computer.  See 

PrimerPro Setup Tutorial for details.  

You will also need a 4,000+ word list, in a Standard Format File or LIFT file, in UTF-8 format.  

This can be created using either Toolbox, FieldWorks or WeSay.  You will also need a 4000+ 

words of edited text (so the spelling is correct!) in plain text files in UTF-8 format.  

A primer usually consists of two kinds of lessons. The first kind is a teaching lesson where you 

are teaching one or more graphemes in the lesson. The second kind is called a review lesson 

where you are not teaching any new grapheme, but instead you are focus on reviewing what has 

been taught already.  These lessons are also used to teach some grammar aspect of the language. 

Starting PrimerPro 

You can start the program by double-clicking on the PrimerPro icon on the desktop. 

Select Project 

The first thing you want to do is select your project that you created in the PrimerPro Setup 

Tutorial.  Below are the steps. 

1. On the File menu, click Select Project. 

The Select Project dialog box appears. 

2. In the list box, select your project and click OK. 

Your project is loaded into the application.  

3. Click OK.. 

Your project is now the current, or active, project.   

Importing Data 

On the status bar, the current word list filename is displayed.  If it is not the correct word list file 

or it is not specified, then you will need to import the correct word list file.  To import the correct 

word list, do the following. 

1. To import the word list file, do one of the following. 



 On the Tools menu, point to Word List, and point to Import and click Standard Format 

Lexicon. This will open a Standard Format Marker (SFM) file. 

 On the Tools menu, point to Word List, and point to Import and click LIFT Lexicon. 

This will open a Lexicon Interchange Format (LIFT) file. 

The Open dialog box appears. 

2. Navigate to and select the desired file, and then click Open. 

The word list is imported into the application. 

3. Click OK after word list has been imported. 

On the status bar, the current text data filename is displayed.  If it is not the correct text data file 

or it is not specified, then you will need to import the correct text data.  To import the correct text 

data, do the following. 

1. On the Tools menu, point to Text Data, and then click Import. 

The Open dialog box appears. 

2. Navigate to and select the desired file, and then click Open. 

The text data is loaded. 

3. Click OK after text data has been imported. 

Sight Words 

You will need to add all the sight words that were taught in the pre-primer. To update the list of 

current sight words, do the following: 

1. On the Tools menu, point to Sight Words, and then click Update Sight Words. 

The Update Sight Words dialog box appears. The list of sight words is displayed.  It should 

be empty at this point. 

2. In the Edit the list box, add the list of sight words, verifying that the box has one sight word 

per line. 

3. When done, click OK. 

First Lesson 

Now you are ready to start making your first lesson.  Below are the steps you will do to 

accomplish this. 

1. Add the first lesson’s grapheme(s) to the graphemes taught list by updating the graphemes 

taught list.  To update the list of current graphemes taught, do the following. 

 On the Tools menu, point to Graphemes Taught, and then click Update Graphemes 

Taught. 

The Update Graphemes Taught dialog box appears. Note that the graphemes taught list 

should be empty.  



 In the Edit the list box, add the grapheme(s) for the first lesson, verifying that the box 

has one grapheme per line. 

 When done, click OK. 

2. Now you want to find words to use in a story for the first lesson.  You can find these words 

using the Buildable Word Search for Word List using only the graphemes in grapheme taught 

list. To run the Buildable Word Search, do the following: 

 On Search menu, point to Word List, and then click Buildable Words Search. 

The Buildable Words Search dialog box appears. 

In the Graphemes box, note that the initial graphemes displayed are those from the 

graphemes taught list. 

 Click OK. 

The results are displayed at the insertion point in the current active document.  A list of 

buildable words from the current word list are displayed, Then print or save to a file the 

displayed word list, noting the useful words for first lesson story. 

To print the displayed word list, do the following.  On the File menu, click Print. The 

Print dialog box appears.  Select the printer and click OK. 

To save to a file the displayed word list, do the following. On the File menu, click Save 

As. The Save As dialog box appears. Navigate to the desired folder and enter the desired 

file name, and then click Save. 

3. If you do not find enough words through the Buildable Word Search for Word List, you can 

use the Buildable Word Search for text Data to find more potential words.  To run the 

Buildable Word Search, do the following 

 On the Search menu, point to Text Data, and then click Buildable Word Search. 

The Buildable Word Search dialog box appears. 

In the Graphemes box, note that the initial graphemes displayed are those from the 

graphemes taught list. 

 Select No Duplicates. 

 Click OK. 

The results appear at the insertion point in the active document.  A list of buildable words 

from the current text data is displayed.   Then print or save to a file the displayed list of 

words, noting the useful words for first lesson’s story. 

4. If you have no nice, pictureable word in your list, and you need one for a keyword, you can 

also use the Grapheme Search on the current word list restricting the search to nouns. Do the 

following. 

 On Search menu, point to Word List, and then click Grapheme Search. 

The Grapheme Search dialog box appears. 



 In the Grapheme to find box, type the desired grapheme, the grapheme that is being 

taught. 

 Click Search Options. 

The Search Options Filter dialog box appears.  

 In the Part of speech box, select Noun, and then click OK. 

The Grapheme Search dialog box reappears. 

 Click OK. 

The results appear at the insertion point in the current active document.  A list of 

potential keywords from the current word list is displayed. 

5. Write a story using buildable words and enter it into a text editor. See Story Checklist
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document for guidelines. Save the story as a UTF-8 plain text. 

6. Make words drills for the primer, after the story has been written. Then you know which 

words should be practiced in advance of the story. 

Make syllable drills for the primer, being sure to give people practice with the syllables used 

in the built words.  

7. Then run a Untaught Residue Search on the story, displaying in paragraph format and 

ignoring sight words. The story should be displayed without any highlighting. Highlighting 

indicates untaught residue.  To run the Untaught Residue Search, do the following. 

 On Search menu, point to Text Data, and then click Untaught Residue Search. 

The Untaught Residue Search dialog box appears. 

 Select Browse. The Open dialog box appears. Navigate to and select the desired story 

file. Then click OK. 

The Untaught Residue Search dialog box reappears. 

 Select Display in Paragraph Format. The results will be displayed in paragraph format.  

 Select Ignore Sight Words. This means any sight word in the current text data will not 

be flagged as a untaught word. 

 Click OK. 

The results appear at the insertion point in the active document. The story file is 

displayed with the graphemes that have not been taught yet highlighted. After the text 

data is displayed, the count of the untaught words is displayed. 

If there are any untaught words, you will need to redo the story, and then check it again. 

8. Create an “All Stories” text file using a text editor in a location of your choosing.  Add the 

story for the first lesson to this file. 

9. Take all data you have collected for the lesson and use it to make the primer's first lesson 

using a publishing tool (e.g. MS Publisher). 



Subsequent Lessons 

Now you are ready to start making your next lesson.  Below are the steps you will do to 

accomplish this. 

1. Add the lesson’s grapheme(s) to the graphemes taught list by updating the graphemes taught 

list.  To update the list of current graphemes taught, do the following. 

 On the Tools menu, point to Graphemes Taught, and then click Update Graphemes 

Taught. 

The Update Graphemes Taught dialog box appears.  

In the Edit the list box, add the grapheme(s) for the lesson to the end of the list, verifying 

that the box has one grapheme per line. 

 When done, click OK. 

2. Check to verify the grapheme taught list contains only valid graphemes. 

 On the Tools menu, point to Graphemes Taught, and then click Check against 

Grapheme Inventory. 

The results should indicate none. 

3. Now you want to find words to use in a story for the lesson.  You can find these words using 

the Buildable Word Search for Word List using only the graphemes in grapheme taught list. 

To run the Buildable Word Search, do the following: 

 On Search menu, point to Word List, and then click Buildable Words Search. 

The Buildable Words Search dialog box appears. 

In the Graphemes box, note that the initial graphemes displayed are those from the 

graphemes taught list. 

 Click OK. 

The results are displayed at the insertion point in the current active document.  A list of 

buildable words from the current word list are displayed, Then print or save to a file the 

displayed word list, noting the useful words for the lesson’s story. 

4. As the graphemes taught list increases, the buildable word list will also increase.  When the 

buildable word list gets too long to manage, you may want to get a list of only the new 

buildable words generated by the graphemes taught in the lesson using the Grapheme Search 

for the word list. To run the Grapheme Search, do the following. 

 On Search menu, point to Word List, and then click Grapheme Search. 

The Grapheme Search dialog box appears. 

 In the Grapheme to find box, type the grapheme being taught by this lesson.  

 Select Restrict to Graphemes Taught.  This will display those words that contain only 

the graphemes in the grapheme taught list. 

 Click OK. 



The results appear at the insertion point in the current active document. It displays a 

subset of the word list that contains the desired grapheme. 

Note that if a word contains any grapheme that is not yet in the grapheme taught list, the 

word will not be displayed, even if it contains the grapheme being taught. 

5. If you do not find enough words through the Buildable Word Search for word list, you can 

use the Buildable Word Search for text data on the current text data to find more potential 

words.  To run the Buildable Word Search, do the following 

 On the Search menu, point to Text Data, and then click Buildable Word Search. 

The Buildable Word Search dialog box appears. 

In the Graphemes box, note that the initial graphemes displayed are those from the 

graphemes taught list. 

 Select No Duplicates. 

 Click OK. 

The results appear at the insertion point in the active document.  A list of buildable words 

from the current text data are displayed.   Then print or save to a file the displayed list of 

words, noting the useful words for the lesson’s story. 

6. As the graphemes taught list increases, the buildable word list will also increase.  When the 

buidable word list gets too long to manage, you may want to get a list of only the new 

buildable words generated by the graphemes taught in the lesson using the Grapheme Search 

for the text data. To run the Grapheme Search, do the following. 

 On Search menu, point to Text Data, and then click Grapheme Search. 

The Grapheme Search dialog box appears. 

 In the Grapheme to find box, type the grapheme being taught by this lesson. 

 Select Restrict to Graphemes Taught. This will display only those words in the text 

data that contain only the graphemes in the grapheme taught list.  

 Select No Duplicates. 

 Click OK. 

The results appear at the insertion point in the active document. It displays a list of words 

from the current text data that contains the desired grapheme. 

Note that if a word contains any grapheme that is not yet in the grapheme taught list, the 

word will not be displayed, even if it contains the grapheme being taught. 

7. If you find interesting pictureable words, take note of them for use as keywords. . If there are 

no built words which are pictureable, you'll need to use Grapheme Search for the word list 

looking only for nouns containing the lesson's grapheme.  

8. Find usable phrases for the story by using the Usable Phrase Search containing only the 

graphemes in the grapheme taught list. Initially you probably will want to use a value of two 

for the minimal number of words in a phrase. Print the list, noting useful phrases for this 

lesson's story. To run the Usable Phrase Search, do the following. 



 On Search menu, point to Text Data, and then click Usable Phrases Search. 

The Usable Phrases Search dialog box appears. 

 In the Minimal number of words in a phrase box, enter the appropriate number This 

restricts a phrase to a minimal number of words. 

 In the Highlight phrases with this grapheme box, enter the grapheme being taught. 

When the list of phrases is displayed, if the grapheme being taught is contained in the 

phrase, then the phrase is highlighted.  

 Click OK. 

The results appear at the insertion point in the active document. A list of potential phrases 

from the current text data for the story is displayed. Print or save to a file the phrase list. 

If the phrase list becomes too long to manage, increase the number in the Minimal 

number of words in a phrase box. As you work through the graphemes taught list, you 

probably will want to increase the minimal number of words in a phrase, to keep the list 

to a manageable size. 

9. Write a story using buildable words and any usable phrases which will help your story be 

natural sounding and give readers practice. For the first two weeks, restrict story size to 12 

words. Later lessons should gradually increase in size, up to 25 or 30 words by the end of the 

primer. 

10. Make words drills for the primer, after the story has been written. Then you know which 

words should be practiced in advance of the story. 

Make syllable drills for the primer, being sure to give people practice with the syllables used 

in the built words.  

11. Enter the story in a word processor. See Story Checklist document for guidelines. Save the 

story as a UTF-8 plain text. Then run a Untaught Residue Search on the story, displaying in 

paragraph format and ignoring sight words. The story should be displayed without any 

highlighting. Highlighting indicates untaught residue.  To run the Untaught Residue Search, 

do the following. 

 On Search menu, point to Text Data, and then click Untaught Residue Search. 

The Untaught Residue Search dialog box appears. 

 Select Browse. The Open dialog box appears. Navigate to and select the desired story 

file. Then click OK. 

The Untaught Residue Search dialog box reappears. 

 Select Display in Paragraph Format. The results will be displayed in paragraph format.  

 Select Ignore Sight Words. This means any sight word in the current text data will not 

be flagged as a untaught word. 

 Click OK. 



The results appear at the insertion point in the active document. The story file is 

displayed with the graphemes that have not been taught yet highlighted. After the text 

data is displayed, the count of the untaught words is displayed. 

If there are any untaught words, you will need to redo the story, and then check it again. 

12. If you want to verify which sight words you are using in the story, run the Sight Word 

Search. To run the Sight Word Search, do the following. 

 On the Search menu, point to Text Data, and then click Sight Word Search. 

The Sight Word Search dialog box appears. 

 Click the Browse button. In the Open dialog box, navigate to and select the story file, 

and then click OK. 

 Click Check All to select all the sight words. 

 Select Display in Paragraph Format to be displayed in paragraph format.  

 Click OK. 

The results appear at the insertion point in the active document. The text data is displayed 

with all the sight words highlighted. 

13. To be sure you’re using enough new words, or not too many, you can check the story to see 

how many new words are in it. 

 On the Search menu, point to Text Data, and then click New Word Search. 

The New Word Search dialog box appears. 

 Select Browse for the Base file. The Open dialog box appears.  Navigate to the “All 

Stories” file.  Then click OK. 

 Select Browse for the Story file. The Open dialog box appears.  Navigate to the story 

file.  Then click OK. 

 Select Display in Paragraph Format. The results will be displayed in paragraph format.  

 Click OK. 

The story is displayed with the new words (words that have not been used in a previous 

story) highlighted.  If there are too many new words, you may need to rewrite the story. 

Add the story for the lesson to the “All Stories” file. 

14. Take all data you have collected for the lesson and use it to make the primer's lesson using a 

publishing tool (e.g. MS Publisher). 

You continue to repeat the Subsequent Lesson section for each teaching lesson of the primer. 

Review Lessons 

Every fifth lesson should be a review lesson. To create a review lesson, consider the following: 

1. See Writing a Review Lesson2 document for details on review lesson design. 



2. Refer to Primer Progression Chart, looking to identify built words and sight words which 

should be practiced. List them and design an exercise which gives the reader practice using 

those words. The exercise should differ somehow from the stories used previously in the 

week. If it is a story, the plot and characters should be different from the usual ones. See 

Writing a Review Lesson document for other ideas. 

3. Choose a simple illustration to accompany the review activity. 

4. Design a short functor lesson. It should consists of two activities. Put your functor activities 

into the template provided. 

5. Mark the times the built and sight words are used, including times they are used in the 

functor exercise, on the Primer Progression Chart. 

6. Record any functor taught in the blank spot for the review lesson in the Primer Progression 

Chart. For example, you would write “assoc. markers ya, wa” in the blank. 

7. Design the “creative writing” syllable boxes. The first review lesson should only contain 12 

syllable boxes. Later review lessons can contain an additional row. List built words used 

frequently in the previous lessons. From this list, choose syllables which occur often in the 

word list. Fill them into boxes, and see how many words (either from the stories or new ones) 

can be made from different syllable boxes. Change as needed. See Writing a Review Lesson 

document for an example. 

Setup Conclusion 

Now you have completed the primer making tutorial.  To exit PrimerPro, do the following. 

 On the File menu, click Exit. 

PrimerPro will remember the last current project and all its option settings.  The next time 

you start PrimerPro, the project will be selected with all its options setting.  The associated 

word list file and text date file will be automatically imported. 

 

                                                 
1
 The Story Checklist document can be found in the Primer Documentation Package at the 

following url: http://www.sil.org/resources/software_fonts/primerpro. 

2
 The Writing a Review Lesson document can be found in the Primer Documentation Package at 

the following url: http://www.sil.org/resources/software_fonts/primerpro. 

 

http://www.sil.org/resources/software_fonts/primerpro
http://www.sil.org/resources/software_fonts/primerpro
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