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1. Introduction

1.1.What is aeneas?
aeneas is a tool designed to “automagically synchronize audio and text”. It takes an
audio file and a list of phrases as inputs. Its output is a synchronization timing file, i.e.
the same kind of labels file you would create manually in Audacity.

The way aeneas works is to synthesize each phrase using a text-to-speech engine, and
then compare the synthesized audio files against the input audio file to find the phrase
breaks. To do this, a lot of clever mathematical computation goes on behind the scenes:

Using the Sakoe-Chiba Band Dynamic Time Warping (DTW) algorithm to align the
Mel-frequency cepstral coefficients (MFCCs) representation of the given (real)
audio wave and the audio wave obtained by synthesizing the text fragments with
a TTS engine, eventually mapping the computed alignment back onto the (real)

time domain.?

Or to illustrate it more simply, the synthesized phrases...
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...are mapped against the input audio file to find phrase breaks.

Best results are obtained:

e if you have a clearly spoken recording,
e if any background music is low enough in volume not to confuse the system,

e if the synthesized phrases correspond well enough to how the language is
pronounced.

! https://github.com/readbeyond/aeneas/#aeneas

2 https://github.com/readbeyond/aeneas/blob/master/wiki/HOWITWORKS.md



1.2. Will it work with our language?

aeneas is producing impressively accurate timing files for languages around the world.
We would recommend you try it out and see how well it works for your text and audio
files.

What about special characters or tone marks? Since the text-to-speech engine copes
best with simple A-Z Roman scripts, the Synchronize using aeneas wizard in Scripture
App Builder has a Character Replacement page, designed to replace special characters
with simple ones (b to b, € to e, etc.). It also strips out accents and tone marks. The
comparison algorithms are tolerant enough to match up the phrases even though the
pronunciation differs.

If you have a non-Roman script, you will need to define a set of character replacements,
transliterating your non-Roman script into a simple A-Z Roman script (31 to a, @ to ka, 3
to u, etc.). This approach has already been used successfully to synchronize text and
audio for the whole of the Hebrew Bible. If you create a set of additional character
replacements that work well for your script and language, please let us know so that we
can add them to the default set of replacements.

You can find a selection of Romanization tables here:
http://www.loc.gov/catdir/cpso/romansource.html

1.3. How long does it take?

For a typical phrase-by-phrase synchronisation, running aeneas takes 1-2 minutes to
process an hour of audio, and less than an hour for all 27 books of the New Testament.
Actual times will depend on the speed of your computer.

1.4. How do we run aeneas?

You need to Install aeneas on your computer and use the Synchronize using aeneas
wizard in SAB to launch the synchronization process.

See section 2 for instructions on how to install aeneas on Windows, and section 3 on
how to install aeneas on Linux. This is especially easy for Ubuntu users since aeneas is
included automatically in the SAB installation.

Windows Installation

To set up aeneas on Windows, there are several programs and modules to download
and install: FFmpeg, eSpeak, Python and aeneas. These can all be installed with a single
setup program.

1. Go to the Download page on the Scripture App Builder website
http://software.sil.org/scriptureappbuilder/download/ and download the latest
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aeneas setup program for Windows. You will find it under the heading Audio
Synchronization Tools.

2. The filename will be something like aeneas-windows-setup-1.7.2.exe.
3. Double-click the file you have downloaded to start the installation wizard.

ﬁ Setup - aeneas tools - X

Welcome to the aeneas tools
Setup Wizard

This will install aeneas 1.7.2 on your computer.

aeneas is a Python library and a set of tools for automated
audio and text synchronization.

In addition to aeneas, the following independent programs
necessary for running aeneas are contained in this installer:
1. FFmpeg

2. eSpeak

3. Python

It is recommended that you close all other applications
before continuing.

Click Mext to continue, or Cancel to exit Setup.

4. Follow the instructions in the wizard. You can accept all the defaults.

5. On the Select Components page, you need the Full Installation which should be
selected by default.



i5 setup - aeneas tools — X

Select Components
Which components should be installed? Ch

Select the components you want to install; clear the components you de not want to
install. Click Next when you are ready to continue.

Full installation L

W @™ m o

Current selection requires at least 290.9 MB of disk space.

6. On the Ready to Install page, click Install.

You will see the wizard running several different installers: for FFmpeg, eSpeak,
Python. It will also install three Python modules.

Before the wizard completes, you should see a command box appear for a few
seconds which verifies the aeneas installation.

BN C:\WINDOWS,system32\emd.exe — O X

aeneas
ffprohe
ffmpeg
espeak
aeneas .tools
shell encoding 0K
aeneas.cdtw COMPILED
aeneas.cmfcc COMFPILED
AENEAS .Ceu COMPILED
All required dependencies are met and all available Python C extensions a
ve compiled
[INFO1 Enjoy running aeneas?

Important: If Scripture App Builder was open while you installed aeneas, close it and
start it again to ensure that it picks up the changes to your Path settings.



3. Linux Installation

If you are using Ubuntu, the aeneas software is a required dependency of Scripture App
Builder. This means that aeneas is automatically installed or updated along with
Scripture App Builder and you do not have to install it manually.

4. Using aeneas within Scripture App Builder

4.1.Running the Audio Synchronization wizard

You can run the Audio Synchronization using aeneas wizard from five places within
Scripture App Builder:

1.

The Audio Files tab for a book or book collection. Select one or more rows in the
table, right-click and select Synchronize using aeneas.

The Audio Synchronization tab for a book collection. Click on the button
Synchronize using aeneas.

The Audio Synchronization tab for a book. Click on the button Synchronize using
aeneas.

The Book Collection tab for a book collection. Right-click on a book and select
Synchronize using aeneas.

The Apps tree on the left of the screen. Right-click on a book or book collection
and select Synchronize using aeneas.

Follow the instructions in the wizard to configure the synchronization.

For Windows users, if the wizard asks, “Where have you installed aeneas?”, please
follow the installation instructions in section 2 of this document.

After the final page of the wizard, the synchronization process will start in a separate
command Window. It runs a batch file (or bash script) which calls an aeneas task for
each chapter of each book.

As timing files are generated you will see their filenames being added to the table on
the Audio Files page.



4.2.Troubleshooting

If the synchronization fails, please ensure that aeneas has been installed correctly. You
can check the installation by selecting Tools > Check aeneas installation... from the
Scripture App Builder main menu.

A common problem on Windows is that eSpeak stops working after a while. To correct
this, run the aeneas Windows setup program again.

To verify that eSpeak has been installed correctly and is in your path, open a new
Windows command prompt and type:

espeak hello

If all is well, you should hear the word “hello” pronounced.

4.3.Viewing and testing the timing files created by aeneas

To view a generated timing file, select a row on the Audio Files page, right-click, and
select View Timing File.

To test the generated timing files with the text and audio, select a row in the Audio Files
page, right-click and select Export to HTML.
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5. Fine Tune Timings

5.1.Fine tune timing files using the Fine Tune Timings viewer

To fine tune a generated timing file:

1. Select a row on the Audio Files page, right-click, and select Fine Tune Timings.

A page should open in your default browser, looking something like this:

@ Mariks 6 x  + = B =
<« C @ File | C:/Users/Richard/Documents/App%20Builder/Scripture%20Apps/HTML%200utput/fine-tu...  ¥r = 0
< Marika 6 >

Labsl | Pheese Tme  Baek  Forward

la Lee kadugo na a Yesu di foro wee xuu wu ni, 0:03.02 -- - + 4
1b kulo lemu ni wa ls ge, 0:06.23 - — = § o
1c na she wa. 0:08.02 -- - = e
1d A wu kalaapiire t'i binne ni wu ni. 0:09.34 - - + 4
2a Ba cadeenge K’a pa no we, 0:11.26 - - + ++
2b a wu she jé cadeenge Ka pa no we, 0:13.42 - - +
2c a wu she jé Kile-peene puga ki ni, 0:13.48 - - o+
2d na no co na sipyii pu kalaa. 0:15.87 - - Fa
2e A sipyinehemee di wu kafila wu logo, 0:18.12 - - + e
2f a I'i bye pu mu kakanhana. 0:20.80 - - + e
2g A p’i ganha na yu na: 0:22.55 - = P
2h «Mii we d’a kii keree kii ta we? 0:24.34 - - + e
2i Te fungongo feere te ta kan wu mu ge, 0:26.31 - - = ==
2j tee ne naha we? 0:28.03 -—- - P
2k Kii kakanhanaa kii di wa byi wu mu dii we? 0:29.28 - - + o+
3a Ta wu ne me Mariyama ja menizhe wu we? 0:32.65 -- - + 4
3b Go wu ceboronamaa pu wa Yakuba. 0:35.44 - - +

P 000/835 =———— )

2. Click on the first row of the table to start the audio playing.

3. Assoon as you hear the first word or two from the selected row, click on the next
row.

4. Continue clicking on each row to listen for enough time to determine whether the
timing break has been placed in the right place, i.e. not too early and not too late.

You can also use the N keyboard shortcut to move to the next row.
5. If you hear that the timing for a row needs to be fine-tuned, click the plus (+) button
to move the start time forward by 0.1 seconds, the double-plus (++) to move

forward by 1 second, the minus (=) button to move the start time backwards by 0.1
seconds, or the double-minus (- —) to move back 1 second.

11
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@ Marika 6 LTS -+
&« C @ File | CfUsers/Richard/Documents/App%20Builder/Scripture%20Apps/HTML%200utput/fine-tuning...  ¥r = N = 0 :
Marika @6

Label Phrase B
la Lee kadugo na a Yesu di foro wee xuu wu ni, ++
1b kulo lemu ni wa le ge, i+
1lc na she wa. i+
1d A wu kalaapiire t'i binns ni wu ni. ++
2a Ba cadeenge k'a pa no we, ++
2b a wu she jé cadeenge a pa no we, i+
2c a wu she jé Kile-peege puga ki ni, i+
2d na no co na sipyij pu kalaa. ++
2e A sipyinehem wu kafila wu logo, i+

2f aI'i bye pum i+
2g A p'i ganha

2h «Mii we d’a

++

++

2i Te fungongy Jere te fa kan wu mu ge, i+
2j tee ne pah, ++
2k Kii kakan] jpaa kii di wa byi wu mu dii we? i+

3a Ta wu ng [e Marivama ja menizhe wu we? ++

3b Go wu ronamaa pu wa Yakuba, ++

3c ni Zho

++

Il 016/835 ——

LJ
Click on each row for enough
time to check if the audio starts Adjust the start time of the
at the right place. currently selected timing using

the plus and minus buttons.

6. When you are happy with the current row, continue clicking on the subsequent
rows in the same way, fine tuning those that need adjusting.

7. When you have reached the last row of the table, save your changes by clicking on
the button Save Changes to Timing File at the bottom of the page (or by using the
keyboard shortcut T).

Important
For security reasons, your browser does not have permission to save the modified

timing file in its original location. It will be saved to your default Downloads folder.
Scripture App Builder can watch this folder for modified files and move them back to
your project data folder. Specify the Downloads folder to watch in Settings > Files.
Otherwise, you will need to move the modified files back to your project manually, e.g.
using the Add Timing Files button.
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5.2.Changing audio speed when doing fine tuning

If the audio is playing too quickly for you to fine tune accurately, you can slow down the
playback speed using the speed selector at the bottom of the screen.

@ Marika 6 x + - o b3
& C @ File | C/Users/Richard/Documents/App%20Builder/Scripture9s20Apps/HTML%200utput/fine-tuning... ¥¢ = N = 0 H
Marika @6

= e =
la Lee kadugo na a Yesu di foro wee xuu wu ni, 0:03.02 - - P
1b kulo lemu ni wa le ge, 0:06.23 - - PO
1c na she wa. 0:08.02 - - e
1d A wu kalaapiire i binns ni wu ni. 0:09.34 - - P
2a Ba cadesnge K'a pa no we, 0:11.26 - +
2b a wu she jé cadeenge kKa pa no we, 0:13.42 - - e
2¢ a wu she jé Kile-peene puga ki ni, 0:13.48 - - e
2d na no co na sipyii pu kalaa, 0:15.87 - - P
2e A sipyinehemee di wu kafila wu logo, 0:18.12 - - D
2f a I'i bye pu mu kakanhana. 0:20.80 -- - e
2g A p’i ganha na yu na: 0:22.55 - - P
2h «Mii we d’a kii keree kii ta we? 0:24.34 - - e
2i Te fungong feere te fa kan wu mu ge, 0:26.31 - - e
2j tee ne naha wed 0:28.03 - - P
2k Kii kakanhara Si wa byi wu mu dii we? 0:29.28 - - e
3a Ta wu pe me [ 1.1x a ja menizhe wu we? 0:32.65 - - P
3b Go wu ceboro&u wa Yakuba, 0:35.44 - - P
3¢ ni Zhose, ggi 0:37.84 - + e

0.6x

0.5x

Normal v P 019/835 e— )

7
&

Change the playback speed here

5.3.Keyboard shortcuts when doing fine tuning

The following keyboard shortcuts are available in the Fine Tuning interface:

Key Action

Spacebar Start/Pause audio

T Save timing file
N Start playing from the next row
P Start playing from the previous row

Set the phrase start time to be at the current audio
position

13



A (orQ) Move the start time of the current row back 1 sec

S Move the start time of the current row back 0.1 secs

b Move the start time of the current row forward 0.1
secs

F Move the start time of the current row forward 1 sec

5.4.Sending Fine Tuning files to others

If you want to do fine tuning well, it can take a lot of time of concentrated listening. You
might have friends and colleagues who are willing to help with this. It is possible to send
them the Fine Tuning files to work on without them needing to install Scripture App
Builder.

To do this:
1. Select one ore more books, or a book collection, right-click, and select Fine Tune
Timings.

2. Inthe Fine Tuning wizard, choose The files will be sent to others to help with
the fine tuning.

3. Onthe next page, Audio Files, choose to copy the audio files (if you have a good
internet connection) or choose not to copy them (if your internet connection is
limited and you will tell your friends where they can download the audio files).

4. On the next page, Zip Files, choose to zip the fine tuning files together to send to
your friends.

5. On the next page, Output Folder, choose where you would like the files to be
created, then click Create Files.

6. Send the files to your friends, ask them to unzip them on their computer, and
explain to them how they can work on the timings. They should send the
modified timing files back to you.

5.5.Fine tune timing files using Audacity
Instead of using the Fine Tune Timings viewer, you can make corrections in Audacity. To
do this:

Open the audio MP3 file in Audacity.

Import the timing file, by selecting File > Import > Labels...

Zoom into the waveform.

Adjust the position of any labels that are not in the right place.

LA e

Export the modified labels track, using File > Export Labels...

14



6. Test the synchronisation again within Scripture App Builder using the Export to
HTML utility (see above) to see if the timing problems have been resolved.

6. Adding voices to eSpeak

By using character replacements in the Synchronize using aeneas wizard, you will find

that you can get good synchronization results for many languages using the existing
eSpeak voices.

Adding a new voice in eSpeak is not easy, but if you would like to try, please follow the
instructions here: http://espeak.sourceforge.net/add language.html

15
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