What operating systems does LingTree run on?

Windows, Mac OS X, and Linux operating systems

What graphic formats does LingTree save the diagram in?

PNG, and/or SVG.

How do I indicate what graphic formats I want LingTree to save the diagram in?

Use File menu item / Save tree as .png and/or Save tree as .svg.

How do I indicate a node is a lexical item?

Type \L before the lexical item.

How do I indicate a node is a gloss item?

Type \G before the gloss item.

How do I indicate a node should have a triangle over it instead of a vertical line?

Type \T before the item.

How do I indicate a node should not have a vertical line or triangle over it?

Type \O before the item.

How do I indicate a part of a node is a subscript?

Type /s before the subscript.

How do I indicate a part of a node is a superscript?

Type /S before the superscript.

Can I have both a subscript and a superscript showing one over the other?

Yes.

How do I set the fonts for nodes, lexical items, and glosses?

Use Format menu item / Non-terminal font or Lexical font or Gloss font or Empty element font.

Can I have curved lines or arrows in the diagram?

No, sorry, not with LingTree.  You can, however, save the basic diagram as an SVG file and then use a tool like Inkscape to add the curved lines and arrows.

I’m wanting to put some LingTree trees into MS Word & PowerPoint files (Office 2007) with a pretty sharp resolution. How would you recommend that I do this?

From what I can tell, only Office 2016+ allows you to insert SVG files. So this means you’ll need to use PNG format. As far as I know, there isn’t a way to take a PNG file and increase its resolution. I do see, however, that we can open an SVG file in InkScape and then export it as PNG. In fact, it looks like we can set the resolution of the PNG file at least to a certain extent.

You can get InkScape for free at https://inkscape.org/. Once it’s installed, try this:

  1. In LingTree, save your LingTree diagrams in SVG format.
  2. In InkScape, use File menu item / Open and navigate to where you have one of these SVG files and load it.
  3. Use File menu item / Export PNG Image…
  4. On the right there will be a box showing information.
  5. Change the Width value to something large (like 2000 or maybe even 5000).
  6. Click on Export.

Now try loading that PNG into Word or PowerPoint. Is the resolution good enough? If not, try making the Width value even higher.